Installing Oracle Service Bus 10gR3 on Mac Os X

Jeroen van Wilgenburg

Last week I installed WebLogic and the AquaLogic Service Bus on a Mac. There is no Mac-download on the download page, but by using the HP-UX version everything works fine, you just have to add some command line parameters.


How to install WebLogic on a Mac is explained in this blog:
Running WebLogic Server 10g Release 3 on a Mac
Make sure you also read the comments on the blog when you get errors, they contain valuable information that'll save you a lot of time.

Go to the Oracle download page and pick the HP-UX Itanium version. I picked the HP-UX version because it's in fact a generic version.

Run the installer on the command line (don't run the jar directly!):

java -Xmx1024m -jar -Dos.name=unix osb103_wls103_generic.jar

Since the WebLogic installer had some memory problems on a Mac I added the -Xmx1024m paramter. The os.name parameter is added to prevent the "Insufficient disk space!" error.

Follow the default installation instructions. When the screen "Choose Products and Components" appears I also included the Service Bus Examples, they might come in handy.

After installing the OSB you have to extend your domain with the Oracle Service Bus (or just create a new domain).
Start the Configuration Wizard ($BEA_HOME/wlserver_10.3/common/bin/config.sh) and pick Extend an existing WebLogic domain (assuming you already have a domain running)
Search for the directory where your domain is running (ie. $BEA_HOME/user_projects/domain/base_domain)

I chose to replace all components when asked for and picked the default choice at every wizard screen.

The changes you made to startWebLogic.sh (see the blog by Yusuke Yamamoto I mentioned earlier) also have to be reapplied.

When you start your domain (with startWebLogic.sh) you should be able to access the Service Bus Console on http://localhost:7001/sbconsole

To check whether things are working I followed the first tutorial.

Sources

Comments (3)

  1. Vanggaard - Reply

    February 25, 2010 at 10:07 pm

    Thanks for your guide. I have a problem getting OSB to run on my Mac so I hope you can/will help me.

    After the installation and I have created a new domain, I try to start the WLS/OSB with ./startWebLogic.sh

    The server starts but a few seconds after it writes "Server state changed to STARTING" I get the message:

    Stopping PointBase server...
    PointBase server stopped.

    And it stops 🙁

    Do you have any ideas?

    Best Regards,
    Vanggaard

  2. Danilo - Reply

    September 20, 2010 at 9:34 pm

    Vanggarard,

    This is a memory issue. Edit startWebLogic.sh and add:
    USER_MEM_ARGS="-Xms256m -Xmx512m -XX:MaxPermSize=256m"

    Danilo

  3. steven - Reply

    April 27, 2016 at 1:13 pm

    Thanks for your useful information, It is very useful to me and others and it is very useful to who are searching for Oracle OSB Online Training.

Add a Comment